Latest News

Hardware Upgrade Notice

📅26 February 2017, 23:48

Only the newest generation 3 hardware is now supported.


All old tools (slaves and masters) will need an upgrade in order to use future software updates!

If you are not sure which hardware you have, you can check using the auto-updater function inside the current release of the MPPS software application, if an upgrade is required the software will inform you.


The upgrade program ends on 01/08/17, after this date it will be no longer possible to upgrade, NO EXCEPTIONS!


The hardware upgrade is no longer available.